IE9 and 10 Support Discontinued

Announcement

As of January 12, 2016, Microsoft has ceased supporting versions of IE prior to version 11. M3 and all related products will follow suit.

What does this mean for Me?

To check your browser version, go to: http://www.whatismybrowser.com. If your browser is anything other than Internet Explorer, OR if your browser is Internet Explorer version 11 or higher, you do not need to do anything. Otherwise, read on.

For users of Windows 7 or higher:

If you are using Internet Explorer in Windows 7, make sure you have upgraded to the latest Internet Explorer. Internet Explorer updates are released through Windows Update. You can follow the methods listed at http://www.wikihow.com/Update-Microsoft-Internet-Explorer to manually upgrade.

For users of Windows Vista or lower:

If you have the option of upgrading to a newer version of Windows, we recommend you do so. Windows 10 comes with IE 11 or the new Edge browser by default.

Windows Vista does not support Internet Explorer beyond version 9. However, there are numerous other browsers which may be installed and which will work perfectly well with M3 on Vista. If you do not have the option of upgrading to a supported version of Windows, consider installing one of these browsers.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk